Problém s napájením

Odpovědět
krtek
Příspěvky: 5
Registrován: 16 lis 2018, 19:47
Reputation: 0

Problém s napájením

Příspěvek od krtek » 31 pro 2018, 11:50

Zdravím přátelé, snažím se zprovoznit arduino, aby mi posílalo informace na web. (Používám Uno a Ethernet shield). Vše funguje, když je arduino připojeno k pc pomocí usb kabelu. Jakmile, ale připojím arduino na externí zdroj začne mi posílat chybné údaje. Zkoušela jsem napájet i přes usb(bez pc) to pro změnu neposílá vůbec. Netušíte v čem by mohl být problém ?

petan
Příspěvky: 350
Registrován: 23 črc 2017, 10:19
Reputation: 0
Kontaktovat uživatele:

Re: Problém s napájením

Příspěvek od petan » 31 pro 2018, 12:16

Pres jaký piny napájíš Arduino? Jakým napětím ho napájíš? Svítí nějaký LEDky na Ethernet shieldu?

jankop
Příspěvky: 551
Registrován: 06 zář 2017, 20:04
Reputation: 0
Bydliště: Brno
Kontaktovat uživatele:

Re: Problém s napájením

Příspěvek od jankop » 31 pro 2018, 13:34

Externí zdroje, které používáš, mají nejspíš nízké napětí. Nebo je vadný stabilizátor na Arduino Uno.

pavel1tu
Příspěvky: 774
Registrován: 26 říj 2017, 08:28
Reputation: 1
Bydliště: Trutnov
Kontaktovat uživatele:

Re: Problém s napájením

Příspěvek od pavel1tu » 31 pro 2018, 13:55

1) mezi UNO a ETHshielad (pokud používáte) - dejte něco nevodivého - tam kolem konektoru napájení na UNO - sem tam se to zkratuje
2) pokud Arduino napátíte 5V musíte ho napájet na PIN 5V
3) pokud Arduino napájíte více volty (min. 7,5V s ETH shieldem) a máte zdroj alespoň 1A a napájíte arduino přes konktor nebo svorku UIN, mělo by to být OK

Arduino si totiž na měření bere referenční napětí z napájení - pokud napětí 5V kolísá, způsobí to nepřesné měření.

Pro přesné měření většina lidí používá ext. modul, který tuto vlastnost nemá, nebo se používají kvalitní 5V DC-DC měniče, z kterých se arduino napájí dosvorky 5V

Doufám že něco pomůže ;)
UNO, NANO, Mikro, PRO mini, DUE
http://pavel1tu.8u.cz/

krtek
Příspěvky: 5
Registrován: 16 lis 2018, 19:47
Reputation: 0

Re: Problém s napájením

Příspěvek od krtek » 01 led 2019, 16:23

Zkoušela jsem napájet zdrojem s 9V ale 150mA ten posílal chybné hodnoty (když jsem ho,ale zkoušela teď neposílal radši nic). Zkusím ještě nekde sehnat zdroj s více ampéry ;)
petan píše:
31 pro 2018, 12:16
Svítí nějaký LEDky na Ethernet shieldu?
Při připojení k pc svítí tak nějak všechny ( kromě RX TX ty blikají)
Při připojení ostatních dvou svítí pouze PWR, bliká FULLD a TX(externi zdroj [9v] jsem nechala zapojený dýl a začal svítit stejně jako u pc)

krtek
Příspěvky: 5
Registrován: 16 lis 2018, 19:47
Reputation: 0

Re: Problém s napájením

Příspěvek od krtek » 02 led 2019, 11:37

Problém vyřešen, bylo to rukama čím jiným :D Asi některý kabel úplně neseděl

Odpovědět

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 1 host